FDP Home Page / FDP Forum / FAQ's

The FDP is made possible by the following companies and individual members like you.
Please use the links below to show them we value their sponsorship.

Sweetwater

Yellowjackets Tube Converters

Jensen Loudspeakers

Apex Tube Matching

Antique Electronics Supply

MOD KITS DIY

WD Music

Amplified Parts


* God bless America and our men and women in uniform *

* Illegitimi non carborundum! *

If you benefit and learn from the FDP and enjoy our site, please help support us and become a Contributing Member or make a Donation today! The FDP counts on YOU to help keep the site going with an annual contribution. It's quick and easy with PayPal. Please do it TODAY!

Chris Greene, Host & Founder

LOST YOUR PASSWORD?

......................................................................

   
FDP Jam
Calendar
Find musicians
in your area!
  Search the Forums  

FDP Forum / Amp Mods, Repairs, and Projects / Supersonic 60- footswitch is causing pedalboard pedals to pop (DC at amp input?)

ruger9

USA/NJ

Feb 20th, 2019 06:29 AM   Edit   Profile  

Short version:
the Fender footswitch doesn't pop. But somehow, by it being plugged into the amp, causes all the pedals that are put in front of the amp to pop LOUDLY. It's definitely the insertion of the footswitch causing it.

Long version:
my pedals were popping incredibly loudly (and they didn't before), did some research, and it seems there could be DC at the amp's input.

I actually ordered a Lehle DC Filter as a quick fix until I had time to figure this out permanently...

FFWD to today: this is a newer Supersonic 60, not the original amp from several years ago; this is the 60W version that came out at the same time the 22W (which I also own) and 100W versions did.

The SS60 makes pedals pop ONLY when the Fender channel footswitch is being used! I didn't use the footswitch at home, I just pushed the front panel buttons to change channels, but started using the footswitch recently with the band. No footswitch plugged in = NO POP. Footswitch plugged in: LOUD pops.

Any ideas? This one is a standard 1/4" cable, not a midi/DIN one like on the SS22.... about what might be the problem if it is apparently sending DC to the amp's input?

(and yes- I did try a couple other cables, same result. Seems like the issue is either in the footswitch itself or maybe the footswitch jack on the amp?)

Peegoo
Contributing Member
**********
**********
**********
****

Just beyond Mars

there's a world of fools
Feb 20th, 2019 10:35 AM   Edit   Profile  

That's an odd one; I wonder if it's a ground loop.

Do you have a meter? Set it to read mV DC.

Turn on your rig, plug in a guitar, and set everything up so you are replicating the problem.

Next, use the meter to test across the amp foot pedal's ground on the foot switch jack, and the ground on the output of the last effects pedal in your chain.

Any voltage there?

ruger9

USA/NJ

Feb 22nd, 2019 04:54 AM   Edit   Profile  

Well, whatever is going on, it appears to be intermittent.... I got back from rehearsal the other night (where I did NOT use the amp's footswitch due to the problem I described above), and now back at home... it doesn't seem to be a problem anymore. The only thing that changed was the amp's location: being hauled to and back from rehearsal. So now I'm thinking it's a lead dress issue, or something is touching something it shouldn't, intermittently, inside the amp... these new PCB amps with their paddle and ribbon connectors are a PITA.

I had an intermittent noise and function issue with the reverb in my SS22, after months of researching and poking around and trying different things, I finally deduced it was a loose paddle connector on the small reverb PCB. I fixed that, and it's been fine ever since. I love these Supersonic amps, I think they're really great, but they're like the modern day jet fighter: when they work, they're unbeatable. But there's just too much to go wrong inside...

FDP Forum / Amp Mods, Repairs, and Projects / Supersonic 60- footswitch is causing pedalboard pedals to pop (DC at amp input?)




Reply to this Topic
Display my email address             Lost your password?
Your Message:
Link Address (URL):
Link Title:




Moderators: Chris Greene  Iron Man  reverendrob  

FDP, LLC Privacy Policy: Your real name, username, and email
are held in confidence and not disclosed to any third parties, sold, or
used for anything other than FDP Forum registration unless you specifically authorize disclosure.

Furtkamp.com 
Internet Application Development

Copyright © 1999-2019 Fender Discussion Page, LLC   All Rights Reserved