FDP Home Page / FDP Forum / FAQ's

The FDP is made possible by the following companies and individual members like you.
Please use the links below to show them we value their sponsorship.

MOD KITS DIY

Antique Electronics Supply

Jensen Loudspeakers

Sweetwater

WD Music

Amplified Parts

Yellowjackets Tube Converters

Apex Tube Matching


* God bless America and our men and women in uniform *

* Illegitimi non carborundum! *

If you benefit and learn from the FDP and enjoy our site, please help support us and become a Contributing Member or make a Donation today! The FDP counts on YOU to help keep the site going with an annual contribution. It's quick and easy with PayPal. Please do it TODAY!

Chris Greene, Host & Founder

LOST YOUR PASSWORD?

......................................................................

   
FDP Jam
Calendar
Find musicians
in your area!
  Search the Forums  

FDP Forum / Amp Mods, Repairs, and Projects / 5E3 Question

pcalu

usa Thumb area Mi

Aug 27th, 2019 08:04 PM   Edit   Profile  

Not all that familiar with Tweed amps or their workings.

What would cause a hum after 3 on the unused channel? Example: using the bright channel I turn up the unused channel past 3 to add some base frequency and after 3 the low-frequency hum.

Turn the unused channel below 3 it goes away. Using a jumper to combine the channels there is no hum at all.

Or is this normal with a 5E3 (other than this issue the amp works fine)

If not normal, any idea what it is, Oscillation? Signal contamination/some form of bleed over into the channel.






pdf64

UK

Aug 28th, 2019 05:39 PM   Edit   Profile  

A 5E3, like most any guitar amp, has its input #1 socket of each channel shorting signal hot to ground if nothing is plugged in to it.
From the symptoms described I suspect that there’s a problem with that shorting contact. If it’s a diy build, is it even wired up right?

pcalu

usa Thumb area Mi

Aug 28th, 2019 08:01 PM   Edit   Profile  

Spot on.

Normal Channel 1st input. Cold weld/not grounded.

5E2x2

Picked the amp up from a guy on Reverb dirt cheap, He was honest, said he bought it from Weber (as in Weber speakers) said he'd had nothing but issues with it.

Opened it up, it's laid out correct... but absolutely the worst solder job I've seen. I've been fixing the welds(touching up or all together redoing ) Normally I'd think this was done by someone who put it together as a kit, but I question that notion, the layout itself looks pretty professional.

Solder training day at Weber? And this was the amp they used to practice on?


(This message was last edited by pcalu at 10:05 PM, Aug 28th, 2019)

FDP Forum / Amp Mods, Repairs, and Projects / 5E3 Question




Reply to this Topic
Display my email address             Lost your password?
Your Message:
Link Address (URL):
Link Title:




Moderators: Chris Greene  Iron Man  reverendrob  

FDP, LLC Privacy Policy: Your real name, username, and email
are held in confidence and not disclosed to any third parties, sold, or
used for anything other than FDP Forum registration unless you specifically authorize disclosure.

Furtkamp.com 
Internet Application Development

Copyright © 1999-2019 Fender Discussion Page, LLC   All Rights Reserved